PBS startup failed because initdb not found.

Description

This issue was seen on power machines:

Start up during installation failed with:

  •  

    •  

      • Error initializing the PBS dataservice
        Error details:
        Creating the PBS Data Service...
        /bin/sh: /opt/pbs/default/pgsql/bin/initdb: not found.
        Error creating PBS datastore

Startup failed.
Check the logs in /usr/local/spool/PBS/server_logs for errors.
Installation of release complete

Checking the date immediately after installation:
Tue Apr 5 16:36:47 PDT 2016

And there seems to be an existing initdb file
rwxr-xr- 1 root system 158820 Apr 05 16:35 /opt/pbs/default/pgsql/bin/initdb

Acceptance Criteria

None

Activity

Show:
pbsproadmin
April 5, 2016, 5:10 AM

<p>Steps to reproduce:</p>

<p>&nbsp;</p>

<p>-bash-3.00$ cat ../answers1.txt</p>

<p><br />
1<br />
y<br />
6200@testlicense<br />
y</p>

<p>-bash-3.00$ #sudo ./INSTALL &lt; ../answers1.txt &amp;&amp; date &amp;&amp; sudo ls -l /opt/pbs/default/pgsql/bin/initdb<br />
...<br />
...<br />
x ./pgsql/share/pg_hba.conf.sample, 4420 bytes, 9 media blocks.<br />
x ./pgsql/share/postgres.bki, 527954 bytes, 1032 media blocks.<br />
x ./pgsql/share/conversion_create.sql, 74932 bytes, 147 media blocks.<br />
Initial installation of release 13.0.0.151487 complete<br />

  •  

    •  

      • PBS Installation Summary<br />
        ***<br />

      • Found new /etc/pbs.conf.abc<br />

      • Replacing /etc/pbs.conf with /etc/pbs.conf.abc<br />

      • Creating new symbolic link /opt/pbs/default to /opt/pbs/abc<br />
        ***<br />

      • Copying startup script.<br />
        ***<br />

      • End of /opt/pbs/abc/etc/pbs_postinstall</p>

<p>Would you like to start PBS now (y|[n])?&nbsp; /opt/pbs/abc/etc/pbs_init.d<br />
Starting PBS<br />
PBS Home directory /usr/local/spool/PBS needs updating.<br />
Running /opt/pbs/default/etc/pbs_habitat to update it.<br />
***<br />

  •  

    •  

      • PBS_HOME is /usr/local/spool/PBS<br />

      • Setting TZ from $TZ<br />

      • Checking for High Performance Network<br />

      • INFO: No High Performance Network detected<br />

      • It appears no High Performance Network is available.<br />

      • If this is incorrect, please see the PBS<br />

      • Administrator's Guide to configure PBS for<br />

      • jobs to be able use the High Performance Network.<br />
        ***<br />

      • Creating new file /usr/local/spool/PBS/pbs_environment<br />

      • setting NLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/%L/%N.cat<br />

      • setting LANG=en_US<br />

      • The PBS Server has been installed in /opt/pbs/default/sbin.<br />
        ***<br />

      • Error initializing the PBS dataservice<br />
        Error details:<br />
        Creating the PBS Data Service...<br />
        /bin/sh: /opt/pbs/default/pgsql/bin/initdb:&nbsp; not found.<br />
        Error creating PBS datastore</p>

<p>Startup failed.<br />
Check the logs in /usr/local/spool/PBS/server_logs for errors.<br />
Installation of release complete<br />
Tue Apr&nbsp; 5 14:01:09 PDT 2016<br />
rwxr-xr-&nbsp;&nbsp;&nbsp; 1 root&nbsp;&nbsp;&nbsp;&nbsp; system&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 156157 Apr 05 14:00 /opt/pbs/default/pgsql/bin/initdb</p>

<p>&nbsp;</p>

pbsproadmin
April 8, 2016, 2:58 AM

<p>Voltaire, any reason why the answer to the question about whether to start or not is '/opt/pbs/13.0.0.151487/etc/pbs_init.d'? Are you sure the answers file is correct?</p>

Assignee

Unassigned

Reporter

Former user

Severity

None

OS

None

Start Date

None

Pull Request URL

None

Components

Priority

Low
Configure